1. Due to hosting difficulties, difficulty maintaining the forum, time issues, etc.; some time later than a week from now (June 9, 2018) but within the next month, this site will be changing adminstrators from us (Fall Family) to the Quandary and moved, and the forum either migrated to other software or ended. If the forum is ended, static versions of the guides and other resources will be preserved. For more information, see Upcoming Administration Change and Possible End of Forum.

Mobile Trouble

Discussion in 'Site Technical Help & Feedback' started by Drakaina, Mar 21, 2016.

  1. Drakaina

    Drakaina Dragon Kitty Tulpamancy System Is a host

    Joined:
    Feb 14, 2016
    Messages:
    175
    Pronouns:
    She/Her
    I don't know if it's just me or not but for some reason this site behaves horribly on my mobile. I've used both the mobile version of the site and desktop version (by ticking the "request desktop site" option in my browser). Used two different browsers as well, Chrome and FireFox, but always the same issues.
    I've also tried entering text in both the quick reply box and full reply page, it's the same in both.

    I can't select any of my text, not easily anyway. I tap and hold to highlight a word and it highlights some other word half up my device screen. I can't enter a line break in the text form. I have to start typing what I want, then move the cursor back to the start of the word and hit return. Tapping seems to move the cursor where I want it to go, its just highlighting that's impossible.

    This is the only site with this issue too. Other sites and forums seem to work fine.
    I'm using and Android device, version 4.something I believe.

    ADDENDUM: Since the move the line break seems to be functioning normally. Highlighting is still the major issue.
     
  2. Falah

    Falah aka the Chiaroscuro

    Joined:
    May 6, 2015
    Messages:
    314
    System/Host:
    The Quandary
    Pronouns:
    They/Them
    Edit: Missed part of your message. At first, I thought this was a problem like the one we experience on mobile, which happens on all sites we visit. But if it's only happening here... hmm.

    We'll open up the site on mobile later today and see if it happens for us.
     
  3. Isatis

    Isatis record longest tail Administrator Moderator Tulpamancy System Is a host

    Joined:
    May 6, 2015
    Messages:
    4
    Pronouns:
    She/Her
    Can you go to Menu > Settings > Mozilla Firefox (last one) > About Firefox and tell me the Firefox version you're running?

    This might be a Chrome/Firefox specific issue, and I'll probably file a bug report on XenForo's forums.
     
  4. Drakaina

    Drakaina Dragon Kitty Tulpamancy System Is a host

    Joined:
    Feb 14, 2016
    Messages:
    175
    Pronouns:
    She/Her
    FireFox is version 45.0.1
    Chrome is version 49.0.2623.91

    I don't know what tulpa.info host's on, but they and Feral Nature, which is hosted on forumotion works fine.

    It would be great if this were a thing that could be fixed. Tulpa Io is one if the sites I really like. Writing on it is just a bit if a pain in the butt when not on my pc right now. :P
     
  5. Falah

    Falah aka the Chiaroscuro

    Joined:
    May 6, 2015
    Messages:
    314
    System/Host:
    The Quandary
    Pronouns:
    They/Them
    Just a small update--we definitely haven't forgotten about this. Still running a few tests, though as Isatis says, it might end up being a bug. :(

    As for hosting, we're hosted on Gandi and the platform is XenForo. I dunno if you have an account on Kinmunity, but do you encounter the same issue there?
     
  6. Drakaina

    Drakaina Dragon Kitty Tulpamancy System Is a host

    Joined:
    Feb 14, 2016
    Messages:
    175
    Pronouns:
    She/Her
    Shiro (kinmunity's owner) and I aren't on friendly terms, so unfortunately I do not have an account there to test on. :P

    Thank you for continuing to chip away at this, I appreciate it. Just to be thorough I changed my mobile's keyboard to make sure it wasn't throwing off my "cursor" position when I tap elsewhere and that was a bust.

    It's inconvenient, but not a total deal breaker. I don't want anyone to stress about it. The site works fine on my desktop, which I should be using more of anyway. :P
     
  7. FallFamily

    FallFamily Forum Goddesses Administrator Moderator Plural System Mixed-Origin System

    Joined:
    May 6, 2015
    Messages:
    574
    Pronouns:
    She/Her, They/Them
    [Hail] Just one quick question. With the server move last weekend, is the site behaving better, worse, or the same on mobile? If all is right, it should be the same but I figure I should ask because if it is not the same, it will give a clue.
     
  8. Drakaina

    Drakaina Dragon Kitty Tulpamancy System Is a host

    Joined:
    Feb 14, 2016
    Messages:
    175
    Pronouns:
    She/Her
    It seems to be working the same. The site in general is more stable (no more "can't connect to server errors"), but the tapping/highlighting location problem is the same.
     
  9. FallFamily

    FallFamily Forum Goddesses Administrator Moderator Plural System Mixed-Origin System

    Joined:
    May 6, 2015
    Messages:
    574
    Pronouns:
    She/Her, They/Them
    [Hail] Thank you. When you say it is more stable now, do you mean since 1-2 weeks ago, or since over a month ago? We've moved twice. The first time should have changed a lot. The second one shouldn't have changed a thing.
     
  10. Drakaina

    Drakaina Dragon Kitty Tulpamancy System Is a host

    Joined:
    Feb 14, 2016
    Messages:
    175
    Pronouns:
    She/Her
    It was probably over a month ago. I was unable to access the site maybe %50+ of the time. Now I have no more connection errors.

    My memory may be off but I recall having a hard time selecting anything on my mobile back then, but now it's just text entry boxes that are giving me problems.
     
  11. Falah

    Falah aka the Chiaroscuro

    Joined:
    May 6, 2015
    Messages:
    314
    System/Host:
    The Quandary
    Pronouns:
    They/Them
    I'm thinking it might be some weird interaction between XenForo and the browsers you're using. Things seem to be normal on my phone, but I'll have to check what it's running.
     
  12. Drakaina

    Drakaina Dragon Kitty Tulpamancy System Is a host

    Joined:
    Feb 14, 2016
    Messages:
    175
    Pronouns:
    She/Her
    I have a sneaking suspicion you're right. The Google Play Store has a number of browsers besides Chrome and Firefox. Over the next couple days I think I'll download a few of them and see if there's any that behave different.

    UPDATE: I had more time than I thought today, so here's my results, all are the most recent version in the Play Store.
    Dolphin: Site loads right and highlighting works right.
    Opera: Same as above
    Chrome Beta: Same as above

    I updated my phone's OS after these (from v5 to v6), and after a couple reinstall, a clear cache and data, it works like it should. The only problem child is Firefox.

    I may be going back to chrome because of space on my mobile, so if we stumble upon a fix or answer for FireFox acting out I'd love to know what it is. Otherwise it probably won't be an issue...well until Google breaks something with an update anyway. ^^;
     
    Last edited: Apr 18, 2016